ETM® System v5.1 Update 4 is recommended only for customers currently running v5.1
who are experiencing the issue described in this article, and those who are
upgrading from a system running v5.0.2 Update 3. It addresses an issue seen in some
highly concurrent environments in which scheduled reports fail with a "SQLException:
Stream has already been closed" error. It also resolves an upgrade issue that only
affects upgrades from v5.0.2 Update 3. See the attached PDF for more details.